Video is ready, Click Here to View ×


▶ Get StarzSoft KeyPass (Free Trial):
▶ Coupon code (30% off for KeyPass): 30OFF-ST

In this video, we’re discussing the latest developments in the jailbreak community, For those of you on iOS 14.6 all the way up to iOS 15.1, a brand new kernel vulnerability has been demonstrated by a security researcher on Twitter. From the looks of it, the vulnerability could be used for iOS Jailbreak purposes, especially for A12+ devices.

The kernel exploit demonstrated by security researcher @realBrightiup a few days back seems to work on iOS 15.1 which is currently the latest signed version, all the way down to iOS 14 making it very useful for updating Unc0ver Jailbreak or Taurine Jailbreak if released. We have no word on releases for now.

As always, do not forget to SUBSCRIBE to stay updated with the latest #iOS and #Jailbreak news, updates, and tutorials!
~ GeoSn0w

▽ Other videos ▽
▶ A12+ SHSH2 Blobs Saving Tutorial:
▶ NEW…